History Synchronization Failed: Message: SQL Server Agent has information logging turned on

SUMMARY

The SentryOne product periodically collects data from the SQL Server Agent log. If the agent log file becomes too large, the overhead associated with simply reading the log can become problematic. To prevent this, SQL Sentry will automatically stop reading the log and begin generating this message if information logging is turned on. 

SYMPTOMS

The following error is generated continuously:

Message: SQL Server Agent has information logging turned on. The log will fill quickly in this state.

Agent log history synchronization will be paused until information logging is turned off.

CAUSE

The error indicates that information logging is enabled for the SQL Server Agent log. With this level of logging, the Agent log fills up quickly and collecting from it in that state can cause performance problems. In order to prevent the performance problems, SentryOne will not synchronize Agent Log information until information logging is turned off. 

RESOLUTION

In order to resolve this message you will need to turn off information logging. Information logging can be turned off for the affected SQL Server instance by right clicking the Error Logs folder under the SQL Server Agent node in the SQL Server Management Studio Object Explorer (Right-click Error Logs > Configure > Agent Log Level > uncheck Information).
 
Here is a screenshot of the agent log configuration page for additional reference:
Have more questions? Submit a request

0 Comments

Article is closed for comments.